WundertreOS - S3 endpoints for keys with special characters broken – Incident details

Experiencing partially degraded performance

S3 endpoints for keys with special characters broken

Identified
Degraded performance
Started about 3 hours ago

Affected

WundertreOS Database

Operational from 5:55 PM to 6:23 PM, Partial outage from 6:23 PM to 12:00 AM

Storage Buckets

Operational from 5:55 PM to 6:23 PM, Partial outage from 6:23 PM to 12:00 AM

Updates
  • Update
    UTC
    Update

    We have implemented a PR rollback to mitigate this issue. We will actively monitor its progress

  • Update
    UTC
    Update

    A likely mitigation has been identified and we are discussing the proper implementation method.

  • Identified
    UTC
    Identified

    We have identified an issue where S3 endpoints for keys with special characters will be broken. We are actively investigating the correct mitigation for this issue.